Some email recipients with Microsoft email servers may be experiencing delays in receiving emails
Incident Report for Qondor
Resolved
This issue has been resolved.
Posted Feb 14, 2019 - 08:47 CET
Identified
Only a small amount of emails have been affected by this issue.
Posted Feb 13, 2019 - 15:52 CET
Update
The issue is affecting some email recipients with Microsoft email servers. Our email provider will try and resend the affected emails.
Posted Feb 13, 2019 - 13:16 CET
Investigating
Some outgoing emails may be delayed in sending to recipients due to the receiving mail server not accepting the email. The affected emails are currently queued and our email provider will continue to automatically retry sending the emails. We are in touch with our email provider and hope to have some more information soon.

We apologise for the inconvenience.
Posted Feb 13, 2019 - 12:00 CET
This incident affected: Email.